[Comment Each Post] Makes Forum Very Very Slow & Also Too Many Queries

  1. joey_tbf

    joey_tbf - Sep 21, 2015 Active Member VIP Member


    For months i could not understand why my forum was so slow.

    I thought it was a different add-on or maybe i had too many add-ons.

    But today i take a few hours and disable each add-on 1 by 1.

    And finally! I found which add-on cause the forum to be very slow. The form list page is very very slow.

    Which add-on? Well it was Comment Each Post

    Default Style

    Comment Each Post - Disabled
    CEP - Disabled

    Comment Each Post - Enabled
    CEP - Enabled

    7 additional quieres. I think it's too much.


    Also i have another problem!

    On XenForo Default Style :
    CEP - Enabled

    On My Custom Style:
    time custom style

    On my Custom Style the Timing is VERY HIGH if i enable Comment Each Post.

    7.1182 Seconds! Why is the Timing so high? And only on my Custom Style.

    Sometimes in my default style happens also, but 98% of time happen in Custom Style.

    Why is this happening?

    is it possible to delete this add-on and install again, without losing my comments? I dont want to lose my comments, or somehow export comments


    also, after i disabled this add-on, and enable again, now when i click leave comment,

    nothing happen,

    #4 Also, in Statistics, It say i have 0 Comments

    but thats not true, i have many comments.


    I also find this

    ErrorException: Fatal Error: Class 'Brivium_CommentEachPost_Model_Post' not found - library/XenForo/Application.php(528) : eval()'d code:1
    Generated By: Unknown Account, 11 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
      ["url"] => string(97) "http://testforum.com/threads/y-cars.1926/page-11"
      ["_GET"] => array(0) {
      ["_POST"] => array(0) {

    too many problems with this add-on, i have to disable it,

    please check and fix this add-on
    Last edited: Sep 21, 2015
  2. Brivium

    Brivium - Sep 21, 2015 XenForo Services Staff Member


    Thank you for your bug report. This issue has already been fixed in the latest released version which you can download at https://brivium.com/resources/comment-each-post.201/updates

    In case you need any more help, feel free to contact us. Thanks for choosing Brivium.

    Best Regards,
    joey_tbf likes this.
  3. joey_tbf

    joey_tbf - Sep 21, 2015 Active Member VIP Member

    wow! many improvements in the update, my forum is now fast again, sidebar has no problem, and i can see old post comments

    excellent update!

    i love this add-on it's important

    thanks for this Capture

  4. fmsc88

    fmsc88 - Dec 31, 2015 Member VIP Member

    @joey_tbf send me your site link to see this add-on active. looks good :)
    joey_tbf likes this.