1. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    got this error

    Callback Brivium_Credits_Listener_Listener::initDependencies is invalid (Invalid Method).


    don't know the answer to this
     
    Loading...
  2. Brivium

    Brivium - Oct 3, 2014 XenForo Services Staff Member

    Credit
    Point
    Hello,

    Please following our guide for upgrade from Credits (Lite)

    Note: This upgrade will use default currency on Credits (free) to be default currency on Credits Premium. Another currencies will be deleted.
    - Point to ACP > Add-ons > List Add-ons > Find Credits and select the options Control > Disable.
    - Upload contents of Upload folder to root directory, overwriting any existing files.
    - Point to ACP > Add-ons > List Add-ons > Find Credits and select the options Control > Upgrade from XML\addon-Brivium_Credits.xml file.

    Regards,
     
    #2
  3. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    No. I have the credits premium addon already...i am upgrading from credits premium to credits premium and get this error.
     
    #3
  4. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    and already did this.....
    UPGRADING:
    - Upload contents of Upload folder to root directory, overwriting any existing files.
    - Point to ACP > Add-ons > List Add-ons > Find Credits Premium and select the options Control > Upgrade from XML\addon-Brivium_Credits.xml file.


    so i followed the rules and got this error
     
    #4
  5. Brivium

    Brivium - Oct 3, 2014 XenForo Services Staff Member

    Credit
    Point
    Please make sure that you upload override all files to your root index.

    Regards,
     
    #5
  6. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    can you be more specific please......do i have to override them in the upload folder which i did or do i have to overwrite them in the "library" folder and js folder
     
    #6
  7. Brivium

    Brivium - Oct 3, 2014 XenForo Services Staff Member

    Credit
    Point
    Please override all files contain on Upload folder to your forum root.

    Regards,
     
    #7
  8. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    Ok. working. Thanks
     
    #8
  9. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    not working correct........where is my ...check visual

    credits

    ik have had the credits [we call it influence] overview in the nav bar but it's gone
     
    #9
  10. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    Thank you very much...........all my customization is gone!!
     
    #10
  11. Paul

    Paul - Oct 3, 2014 Member

    Credit
    Point
    I had this in my navbar- number of [credits] shown...now it's gone. see visual.
    what is the code to do this again?

    stats2
     
    #11
  12. Brivium

    Brivium - Oct 3, 2014 XenForo Services Staff Member

    Credit
    Point
    Hello,

    You should to grant permission for specific usergroup to allow them to use & see Credits System.

    Regards,
     
    #12
  13. Paul

    Paul - Oct 4, 2014 Member

    Credit
    Point
    Yes I know.

    could you please give me the string how to show the numbers on the navbar

    stats2
     
    #13
  14. Brivium

    Brivium - Oct 4, 2014 XenForo Services Staff Member

    Credit
    Point
    You can use following code and add to template BRC_navigation_visitor_tabs_end
    Code:
    {xen:helper brc_currencyformat, {$user.{$currency.column}},true,{$currency.currency_id}}
    Replace currency_id = your credits currency ID.

    Regards,
     
    #14
  15. Paul

    Paul - Oct 4, 2014 Member

    Credit
    Point
    Thanks......where to put in exactly in the template...on wahat position [line]? I've tried several positions but they not show in the navbar
     
    #15
  16. Brivium

    Brivium - Oct 6, 2014 XenForo Services Staff Member

    Credit
    Point
    Hello,

    Please make sure that you currency column and id are being replaced appropriate.

    Regards,
     
    #16
  17. Paul

    Paul - Oct 6, 2014 Member

    Credit
    Point
    Sorry. can't get it to work. First you say "add", then you say "replace". what do i have to do .....replace or add?
     
    #17