Event Listeners Server Erros while add-on disabled

  1. joey_tbf

    joey_tbf - Mar 10, 2015 Active Member VIP Member

    Credit
    Point
    I am trying to figure out which add-on is causing my forum to be slow. So i disabled all my add-ons.

    I disabled your credits premium add-on for 1 day and i started noticing server errors in my log.

    What's going on? Why am i recieving errors while the add-on is disabled. The other add-ons are not doing this.




    ----



    ErrorException: Fatal Error: Class 'Brivium_BriviumHelper_EventListeners' not found - library/Brivium/Credits/Listener/Listener.php:4
    Generated By: Unknown Account, Today at 4:37 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(94) "http://www.website.com/index.php?threads/cars-update-daily.90216/page-134"
    ["_GET"] => array(1) {
    ["threads/cars-update-daily_90216/page-134"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }




    -------


    Error Info
    Zend_Exception: No entry is registered for key 'brcEvents' - library/XenForo/Application.php:1007
    Generated By: appleby, Today at 5:01 AM
    Stack Trace
    #0 /home/forum/website.com/library/Brivium/Credits/Model/Credit.php(71): XenForo_Application::get('brcEvents')
    #1 /home/forum/website.com/library/Brivium/Credits/ControllerPublic/Login.php(11): Brivium_Credits_Model_Credit->updateUserCredit('login', 2603)
    #2 /home/forum/website.com/library/XenForo/FrontController.php(347): Brivium_Credits_ControllerPublic_Login->actionLogin()
    #3 /home/forum/website.com/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home/forum/website.com/index.php(13): XenForo_FrontController->run()
    #5 {main}
    Request State
    array(3) {
    ["url"] => string(32) "http://website.com/login/login"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(6) {
    ["login"] => string(11) "appleby"
    ["password"] => string(8) "********"
    ["register"] => string(1) "0"
    ["remember"] => string(1) "1"
    ["redirect"] => string(1) "/"
    ["_xfToken"] => string(8) "********"
    }
    }
     
    Last edited: Mar 10, 2015
    Loading...
  2. Brivium

    Brivium - Mar 10, 2015 XenForo Services Staff Member

    Credit
    Point
    Could you please submit a ticket that contains a FTP account ? We will check for you.

    Regards,
     
    joey_tbf likes this.
    #2