1. joey_tbf

    joey_tbf - Jun 18, 2015 Active Member VIP Member

    Credit
    Point
    I just upgraded Int Permission add-on and it is not working with Credits 2.0 Beta 2

    I can upgrade add-on but afterwards i get this error in the server errors


    Code:
    ErrorException: Fatal Error: Cannot redeclare class Brivium_StoreProduct_Permission_ActionHandler - library/Brivium/StoreProduct/IntPermission/ActionHandler.php:8
    Generated By: admin, A moment ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
      ["url"] => string(52) "http://website.com/testforum/admin.php?brc-events/"
      ["_GET"] => array(1) {
        ["brc-events/"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }



    also when i go to "Create new product" "Int permission"

    i get a blank page

    http://website.com/testforum/admin.php?brs-products/add


    also when i go to "credits" "list events".

    I get a blank page

    http://website.com/testforum/admin.php?brc-events/



    if i disable the Int Permission add-on. I can view list events page.


    So it seems it is not compatible with Credits 2.0 beta 2.


    you know my test forum password.


    u can check


    .
    .
     
    Last edited: Jun 18, 2015
    Loading...
  2. Brivium

    Brivium - Jun 18, 2015 XenForo Services Staff Member

    Credit
    Point
    joey_tbf likes this.
    #2
  3. joey_tbf

    joey_tbf - Jun 18, 2015 Active Member VIP Member

    Credit
    Point
    I updated to the new version. But it did not fix the problem. I am still seeing a blank page when create new product and list event


    Code:
    ErrorException: Fatal Error: Cannot redeclare class Brivium_StoreProduct_Permission_ActionHandler -library/Brivium/StoreProduct/IntPermission/ActionHandler.php:8
    Generated By: [URL='http://website.com/testforum/admin.php?users/admin.1/edit']admin[/URL], 2 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
      ["url"] => string(60) "http://website.com/testforum/admin.php?tools/cache-rebuild"
      ["_GET"] => array(1) {
        ["tools/cache-rebuild"] => string(0) ""
      }
      ["_POST"] => array(8) {
        ["process"] => string(1) "1"
        ["caches"] => string(15) "[["Credit",[]]]"
        ["position"] => string(1) "0"
        ["redirect"] => string(54) "http://website.com/testforum/admin.php?tools/rebuild"
        ["_xfToken"] => string(8) "********"
        ["_xfRequestUri"] => string(40) "/testforum/admin.php?tools/cache-rebuild"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    


    maybe it is not int perrmisson? but maybe it is flag permission?



    u can check my test forum
     
    #3
  4. Brivium

    Brivium - Jun 18, 2015 XenForo Services Staff Member

    Credit
    Point
    Could you please upload override all files from the latest version and check it again ?
     
    joey_tbf likes this.
    #4
  5. joey_tbf

    joey_tbf - Jun 19, 2015 Active Member VIP Member

    Credit
    Point
    I delete the files and re-upload the files and now it works
     
    #5