1. rafass

    rafass - Aug 5, 2015 Active Member VIP Member

    Credit
    Point
    Hello Brivium.
    I've updated to the last version and now I'm generating this server error filtering in the resource manager:

    Server Error

    Mysqli prepare error: Unknown column 'Resource.prefix_id' in 'where clause'
    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    5. Zend_Db_Adapter_Abstract->fetchOne() in XenResource/Model/Resource.php at line 134
    6. XenResource_Model_Resource->countResources() in XenResource/ControllerPublic/Resource.php at line 386
    7. XenResource_ControllerPublic_Resource->actionCategory() in bdCache/XenResource/ControllerPublic/Resource.php at line 7
    8. bdCache_XenResource_ControllerPublic_Resource->actionCategory() in XenForo/FrontController.php at line 347
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    10. XenForo_FrontController->run() in /home/foro/public_html/index.php at line 13
    PHP:
    Server Error Log
    Error Info
    Zend_Db_Statement_Mysqli_Exception
    Mysqli prepare errorUnknown column 'Resource.prefix_id' in 'where clause' library/Zend/Db/Statement/Mysqli.php:77
    Generated By
    RafassA moment ago
    Stack Trace
    #0 /home/foro/public_html/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('\n\t\t\tSELECT COUN...')
    #1 /home/foro/public_html/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), '\n\t\t\tSELECT COUN...')
    #2 /home/foro/public_html/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('\n\t\t\tSELECT COUN...')
    #3 /home/foro/public_html/library/Zend/Db/Adapter/Abstract.php(825): Zend_Db_Adapter_Abstract->query('\n\t\t\tSELECT COUN...', Array)
    #4 /home/foro/public_html/library/XenResource/Model/Resource.php(134): Zend_Db_Adapter_Abstract->fetchOne('\n\t\t\tSELECT COUN...')
    #5 /home/foro/public_html/library/XenResource/ControllerPublic/Resource.php(79): XenResource_Model_Resource->countResources(Array)
    #6 /home/foro/public_html/library/bdCache/XenResource/ControllerPublic/Resource.php(25): XenResource_ControllerPublic_Resource->actionIndex()
    #7 /home/foro/public_html/library/XenForo/FrontController.php(347): bdCache_XenResource_ControllerPublic_Resource->actionIndex()
    #8 /home/foro/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /home/foro/public_html/index.php(13): XenForo_FrontController->run()
    #10 {main}
    Request State
    array(3) {
      [
    "url"] => string(38"https://mysite/resources/?prefix_id=3"
      
    ["_GET"] => array(1) {
        [
    "prefix_id"] => string(1"3"
      
    }
      [
    "_POST"] => array(0) {
      }
    }

    Thanks for your help!
    .
    .
     
    Loading...
  2. Brivium

    Brivium - Aug 5, 2015 XenForo Services Staff Member

    Credit
    Point
    Hello,

    We've just tried with the newest version and didn't face with your error. Could you please try to disable db cache add-on and check it again ?

    Regards,
     
    #2