1. Joshua4550

    Joshua4550 - Aug 30, 2016 New Member

    Credit
    Point
    Uploaded all files, and just imported the second XML under parent Stylium

    Previously already used Molybdenum theme

    I get error importing......


    An exception occurred: message.css - Line 27: Invalid math expression in /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler.php on line 991
    1. XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Function/Calc.php at line 189
    2. XenForo_Template_Compiler_Function_Calc->_parseMathExpression() in XenForo/Template/Compiler/Function/Calc.php at line 55
    3. XenForo_Template_Compiler_Function_Calc->compile() in XenForo/Template/Compiler.php at line 700
    4. XenForo_Template_Compiler->compileFunction() in XenForo/Template/Compiler.php at line 576
    5. XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    6. XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
    7. XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1601
    8. XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1379
    9. XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1329
    10. XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1268
    11. XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
    12. XenForo_Deferred_Template->execute() in XenForo/Model/Deferred.php at line 295
    13. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    14. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
    15. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
    16. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 131
    17. XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 637
    18. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    19. XenForo_FrontController->run() in /home/mydomain/public_html/mysubfolder/admin.php at line 13

    So theme is completely broke? Just paid!!

    Thanks
     
    Loading...
  2. Joshua4550

    Joshua4550 - Aug 30, 2016 New Member

    Credit
    Point
    Here's the error from the error log in xenforo..
    Server Error Log
    Error Info
    XenForo_Template_Compiler_Exception: message.css - Line 27: Invalid math expression - library/XenForo/Template/Compiler.php:991
    Generated By: My XenForo, 6 minutes ago
    Stack Trace
    #0 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler/Function/Calc.php(189): XenForo_Template_Compiler->getNewCompilerException(Object(XenForo_Phrase)) #1 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler/Function/Calc.php(55): XenForo_Template_Compiler_Function_Calc->_parseMathExpression(Object(XenForo_Template_Compiler), 'intval(?) + 5', Array) #2 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler.php(700): XenForo_Template_Compiler_Function_Calc->compile(Object(XenForo_Template_Compiler), 'calc', Array, Array) #3 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler.php(576): XenForo_Template_Compiler->compileFunction('calc', Array, Array) #4 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler.php(509): XenForo_Template_Compiler->compileSegment(Array, Array) #5 /home/mydomain/public_html/mysubfolder/library/XenForo/Template/Compiler.php(372): XenForo_Template_Compiler->compileSegments(Array) #6 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Template.php(1601): XenForo_Template_Compiler->compileParsed(Array, 'message.css', 5, 0) #7 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Template.php(1379): XenForo_Model_Template->compileAndInsertParsedTemplate(2008, Array, 'message.css', 5) #8 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Template.php(1329): XenForo_Model_Template->compileTemplateInStyleTree(Array) #9 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Template.php(1268): XenForo_Model_Template->compileNamedTemplateInStyleTree('message.css', 5) #10 /home/mydomain/public_html/mysubfolder/library/XenForo/Deferred/Template.php(36): XenForo_Model_Template->compileAllTemplates(6.74079203606, 0, 565) #11 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Template->execute(Array, Array, 6.74079203606, 'Rebuilding... T...') #12 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 6.74079203606, 'Rebuilding... T...', false) #13 /home/mydomain/public_html/mysubfolder/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 6.7407951355, 'Rebuilding... T...', false) #14 /home/mydomain/public_html/mysubfolder/library/XenForo/ViewRenderer/Abstract.php(352): XenForo_Model_Deferred->run(true, 6.7407951355) #15 /home/mydomain/public_html/mysubfolder/library/XenForo/ViewRenderer/HtmlAdmin.php(131): XenForo_ViewRenderer_Abstract::hasManualDeferredToRun(true) #16 /home/mydomain/public_html/mysubfolder/library/XenForo/FrontController.php(637): XenForo_ViewRenderer_HtmlAdmin->renderContainer(Object(XenForo_Template_Admin), Array) #17 /home/mydomain/public_html/mysubfolder/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Error), Object(XenForo_ViewRenderer_HtmlAdmin), Array) #18 /home/mydomain/public_html/mysubfolder/admin.php(13): XenForo_FrontController->run() #19 {main}
    Request State
    array(3) { ["url"] => string(58) "http://mysubfolder/admin.php?tools/run-deferred" ["_GET"] => array(1) { ["tools/run-deferred"] => string(0) "" } ["_POST"] => array(3) { ["redirect"] => string(47) "http://mysubfolder/admin.php?styles/" ["execute"] => string(1) "1" ["_xfToken"] => string(8) "********" } }
     
    #2
  3. Brivium

    Brivium - Aug 30, 2016 XenForo Services Staff Member

    Credit
    Point
    Hello,

    Please make sure that you're using an appropriate style version with your XenForo version.

    Regards,
     
    #3
  4. Joshua4550

    Joshua4550 - Aug 30, 2016 New Member

    Credit
    Point
    XenForo 1.5.6


    advise.... there's no docs on what version to use..
     
    #4
  5. Lisa Nguyen

    Lisa Nguyen - Aug 30, 2016 Brivium Tester Staff Member VIP Member

    Credit
    Point
    #5